وب سایت رسمی قالب چند منظوره پلاسما
آخرین قالبی که می خرید ...

آشنایی با شیوه دانلود و نصب قالب پلاسما


در آموزش آشنایی با شیوه دانلود و نصب قالب پلاسما سعی شده تا حد امکان توضیحات بصورت ساده و قابل فهم باشد، تا کاربرانی که قصد دارند طراحی سایت را با این قالب شروع کنند نیز بتوانند مفاهیم را بطور واضح درک کنند. محتوای این بخش شما را از لحظه دریافت فایل از وب سایت ژاکت تا راه اندازی کامل دمو پلاسما آشنا می کند.

توجه : اگر در آپلود فایل فشرده بسته نصبی مشکل دارید آموزش نصب ساده بسته نصبی از سرور را مشاهده کنید.

لینک اشاره شده در آموزش را در بخش زیر میتوانید مشاهده کنید:

http://yourdomain.com/installer.php

چنانچه میخواهید از این قالب در لوکال هاست استفاده کنید، میتوانید از آموزش فعال سازی ioncube loader در لوکال هاست استفاده کنید :

https://www.zhaket.com/content/installing-ioncube-loader

کد های اضافه شده به htaccess برای رفع محدودیت:

php_value upload_max_filesize 100M
php_value post_max_size 100M
php_value max_input_time 300
php_value max_execution_time 900
php_value memory_limit 256M
php_value max_input_vars 3000

توجه : اگر در سی پنل فایل htaccess رو مشاهده نمی کنید، از قسمت بالا سمت راست روی settings کلیک کرده و تیک گزینه Show Hidden Files (dotfiles) رو بزنید.

در برخی هاست ها به دلایل امنیتی رفع محدودیت به این شکل قابل انجام نیست، به همین دلیل میتونید بجای استفاده از این روش فایل زیر رو دانلود کرده و در مسیر اصلی وردپرس آپلود نمایید. ( فایل رو از حالت فشرده خارج کنید، سپس محتوای اون رو آپلود کنید )

دریافت فایل

کد اضافه شده به wp-config.php :

define( 'WP_MEMORY_LIMIT', '96M' );

اگر با ارور زیر مواجه شدید: 

Warning: session_start(): Cannot start session when headers already sent in /home/…/themes/plusma/menu_plasma.php on line 0

بخشی هست که در تمام هاست ها معمولا فعاله و برای شما فعال نیست. برای این منظور کد زیر رو به htaccess اضافه کنید.

php_flag output_buffering On

نکته مهم

1. نیازی نیست پوشه ای که ما با نام zhaket ایجاد کردیم را ایجاد کنید و می توانید مستقیم در مسیر اصلی محتوا را ایجاد کنید.

2. برای استفاده از این قالب ، شما باید  WordPress 5  یا بالاتر ، نسخه PHP 7.2  یا بالاتر را اجرا کنید ( سایت وردپرس رسما پیشنهاد می کند از PHP 7.3 استفاده کنید .

3. قبل از استفاده از این قالب، باید حتما دانش کافی از سیستم مدیریت وردپرس داشته باشید، و بدانید چگونه می توانید مالکیت سایت جدید خود را بدست بگیرید.

4. پلاسما و سایر افزودنی های آن بسیار سبک طراحی شده و توسط چندین سرویس میزبانی تست شده اما با این وجود اگر از هاست ضعیف استفاده کنید، به دلیل عدم پشتیبانی کافی، ممکن است با مشکلاتی روبرو شوید.

توجه داشته باشید اگرچه برخی هاست ها هزینه کمی برای ارائه سرویس دریافت می کنند ولی ممکن است کیفیت مطلوبی نداشته و در ادامه مشکلات فراوانی برای شما بوجود بیاورند، یا حتی ممکن است در ابتدای کار از این قالب پشتیبانی نکنند.

از میان هاست هایی که اخیرا مورد بررسی قرار دادیم هاست ایران سرور به خوبی این قالب رو پشتیبانی می کند.